summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 84378ab..fea8bdc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,8 +3,12 @@ root_sbindir = "/sbin"
root_sbin_PROGRAMS = mount.cifs
mount_cifs_SOURCES = mount.cifs.c mtab.c util.c
+man_MANS = mount.cifs.8
+
+if CONFIG_CIFSUPCALL
sbin_PROGRAMS = cifs.upcall
cifs_upcall_SOURCES = cifs.upcall.c data_blob.c asn1.c spnego.c util.c
cifs_upcall_LDADD = -ltalloc -lkrb5 -lkeyutils
+man_MANS += cifs.upcall.8
+endif
-man_MANS = cifs.upcall.8 mount.cifs.8