summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoratheik <atteh.mailbox@gmail.com>2022-05-01 00:47:54 +0300
committerPavel Shilovsky <piastryyy@gmail.com>2022-06-13 10:45:18 -0700
commitd9f5447afbbe7d54f1315e6e2a246fc1a1fce311 (patch)
tree9f7c0bbbe045070562dea79e54db46286bf32ca9 /Makefile.am
parent5e5aa507f4c4954ed537a7dfc75cf69915727757 (diff)
downloadcifs-utils-d9f5447afbbe7d54f1315e6e2a246fc1a1fce311.tar.gz
cifs-utils-d9f5447afbbe7d54f1315e6e2a246fc1a1fce311.tar.bz2
cifs-utils-d9f5447afbbe7d54f1315e6e2a246fc1a1fce311.zip
cifs-utils: make GSSAPI usage compatible with Heimdal
The gssapi symbols are in gssapi_krb5 and gssapi in MIT and Heimdal Kerberos, respectively. Including gssapi_generic.h is not necessary. Signed-off-by: atheik <atteh.mailbox@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 38babb3..a15392d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,7 @@ sbin_PROGRAMS =
if CONFIG_CIFSUPCALL
sbin_PROGRAMS += cifs.upcall
cifs_upcall_SOURCES = cifs.upcall.c data_blob.c asn1.c spnego.c
-cifs_upcall_LDADD = -ltalloc -lkeyutils -lgssapi_krb5 $(KRB5_LDADD) $(CAPNG_LDADD)
+cifs_upcall_LDADD = -ltalloc -lkeyutils $(GSSAPI_LDADD) $(KRB5_LDADD) $(CAPNG_LDADD)
rst_man_pages += cifs.upcall.8
#
# Fix the pathnames in manpages. To prevent @label@ being replaced by m4, we