summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2010-02-09 15:22:30 -0500
committerJeff Layton <jlayton@redhat.com>2010-02-09 15:22:30 -0500
commit032cee45ecb3933913509d584ce98017db4f00e0 (patch)
tree57ebccb62525a84e94d1c74d4fddbea302942289 /configure.ac
parente2388fa0ecb6fad2b833d72075062855200e3cda (diff)
downloadcifs-utils-032cee45ecb3933913509d584ce98017db4f00e0.tar.gz
cifs-utils-032cee45ecb3933913509d584ce98017db4f00e0.tar.bz2
cifs-utils-032cee45ecb3933913509d584ce98017db4f00e0.zip
autoconf: reshuffle header and function checking
Make sure we bail out if necessary functions and headers aren't present. Signed-off-by: Jeff Layton <jlayton@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f4a302e..ac1316d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,8 +16,7 @@ AC_PROG_CC
# Checks for header files.
AC_USE_SYSTEM_EXTENSIONS
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h mntent.h netdb.h stddef.h stdint.h stdlib.h string.h strings.h sys/mount.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h])
-AC_CHECK_HEADERS([krb5.h talloc.h], , [AC_MSG_ERROR([necessary header(s) not found])])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h mntent.h netdb.h stddef.h stdint.h stdlib.h string.h strings.h sys/mount.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h krb5.h talloc.h], , [AC_MSG_ERROR([necessary header(s) not found])])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -36,6 +35,11 @@ AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_FUNC_STRNLEN
-AC_CHECK_FUNCS([alarm atexit endpwent getmntent getpass gettimeofday inet_ntop memset realpath setenv strchr strdup strerror strncasecmp strndup strpbrk strrchr strstr strtol strtoul uname krb5_principal_get_realm krb5_free_unparsed_name])
+
+# check for required functions
+AC_CHECK_FUNCS([alarm atexit endpwent getmntent getpass gettimeofday inet_ntop memset realpath setenv strchr strdup strerror strncasecmp strndup strpbrk strrchr strstr strtol strtoul uname], , [AC_MSG_ERROR([necessary functions(s) not found])])
+
+# non-critical functions (we have workarounds for these)
+AC_CHECK_FUNCS([krb5_principal_get_realm krb5_free_unparsed_name])
AC_OUTPUT