summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShirish Pargaonkar <shirishpargaonkar@gmail.com>2011-08-25 14:16:23 -0400
committerJeff Layton <jlayton@samba.org>2011-08-25 14:16:23 -0400
commit06678a909ee842193b95b140fb198f85e3addfef (patch)
treefed4cb2982f502a4e82acc11357162963e7419e9 /configure.ac
parent5ee1ac229d3738520d308e4ddcd170b9b5026ceb (diff)
downloadcifs-utils-06678a909ee842193b95b140fb198f85e3addfef.tar.gz
cifs-utils-06678a909ee842193b95b140fb198f85e3addfef.tar.bz2
cifs-utils-06678a909ee842193b95b140fb198f85e3addfef.zip
cifsacl: Add configure and make directives for cifsacl (try #2)
Add configure directives for option cifsacl. The default action is to enable cifsacl option. cifsacl option is enabled or disabled in a similar way to cifs.idmap in the same function. In addition, for cifsacl, check for sys/xattr.h is done in the smae .m4 file. Add directives to build getcifsacl in Makefile. Signed-off-by: Shirish Pargaonkar <shirishpargaonkar@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a9ad75..2541f39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,12 @@ AC_ARG_ENABLE(cifsidmap,
enable_cifsidmap=$enableval,
enable_cifsidmap="maybe")
+AC_ARG_ENABLE(cifsacl,
+ [AC_HELP_STRING([--enable-cifsacl],
+ [Create get/set cifsacl binary @<:@default=yes@:>@])],
+ enable_cifsacl=$enableval,
+ enable_cifsacl="maybe")
+
# Checks for programs.
AC_PROG_CC
AC_PROG_SED
@@ -94,6 +100,16 @@ if test $enable_cifsupcall != "no" -o $enable_cifsidmap != "no"; then
fi
])
fi
+if test $enable_cifsacl != "no"; then
+ AC_CHECK_HEADERS([wbclient.h], , [
+ if test "$enable_cifsacl" = "yes"; then
+ AC_MSG_ERROR([wbclient.h not found, consider installing libwbclient-devel.])
+ else
+ AC_MSG_WARN([wbclient.h not found, consider installing libwbclient-devel. Disabling getcifsacl.])
+ enable_cifsacl="no"
+ fi
+ ])
+fi
if test $enable_cifsupcall != "no"; then
AC_CHECK_LIB([krb5], [krb5_init_context],
[ KRB5_LDADD='-lkrb5' ],
@@ -156,6 +172,7 @@ LIBS=$cu_saved_libs
AM_CONDITIONAL(CONFIG_CIFSUPCALL, [test "$enable_cifsupcall" != "no"])
AM_CONDITIONAL(CONFIG_CIFSCREDS, [test "$enable_cifscreds" = "yes"])
AM_CONDITIONAL(CONFIG_CIFSIDMAP, [test "$enable_cifsidmap" != "no"])
+AM_CONDITIONAL(CONFIG_CIFSACL, [test "$enable_cifsacl" != "no"])
LIBCAP_NG_PATH