summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShirish Pargaonkar <shirishpargaonkar@gmail.com>2011-06-01 15:27:10 -0400
committerJeff Layton <jlayton@samba.org>2011-06-01 15:27:10 -0400
commit7c04b90be021e03bc2ab97a9c91f66635cdca30b (patch)
treefe8d99a7e4e394018134cf9a4694cc42a74885d0 /configure.ac
parentcbce1a68c419301904ad1fdc7c55b1d3b86fbdff (diff)
downloadcifs-utils-7c04b90be021e03bc2ab97a9c91f66635cdca30b.tar.gz
cifs-utils-7c04b90be021e03bc2ab97a9c91f66635cdca30b.tar.bz2
cifs-utils-7c04b90be021e03bc2ab97a9c91f66635cdca30b.zip
cifs-utils: Create man pages for cifs.idmap program (try #2)
Create man pages for program cifs.idmap Enable cifs.idmap config option by default. Signed-off-by: Shirish Pargaonkar <shirishpargaonkar@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6cac703..e21f23e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ AC_ARG_ENABLE(cifsidmap,
[AC_HELP_STRING([--enable-cifsidmap],
[Create cifs.idmap binary @<:@default=no@:>@])],
enable_cifsidmap=$enableval,
- enable_cifsidmap="no")
+ enable_cifsidmap="maybe")
# Checks for programs.
AC_PROG_CC
@@ -88,6 +88,9 @@ if test $enable_cifsupcall != "no" -o $enable_cifsidmap != "no"; then
fi
if test "$enable_cifsidmap" = "yes"; then
AC_MSG_ERROR([keyutils.h not found, consider installing keyutils-libs-devel.])
+ else
+ AC_MSG_WARN([keyutils.h not found, consider installing keyutils-libs-devel. Disabling cifs.idmap.])
+ enable_cifsidmap="no"
fi
])
fi
@@ -152,7 +155,7 @@ LIBS=$cu_saved_libs
AM_CONDITIONAL(CONFIG_CIFSUPCALL, [test "$enable_cifsupcall" != "no"])
AM_CONDITIONAL(CONFIG_CIFSCREDS, [test "$enable_cifscreds" = "yes"])
-AM_CONDITIONAL(CONFIG_CIFSIDMAP, [test "$enable_cifsidmap" = "yes"])
+AM_CONDITIONAL(CONFIG_CIFSIDMAP, [test "$enable_cifsidmap" != "no"])
LIBCAP_NG_PATH