summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2010-02-26 21:36:45 -0500
committerJeff Layton <jlayton@redhat.com>2010-02-26 21:36:45 -0500
commit8ddbdf13169ac38ef7fe552de5abc683e6d63c0f (patch)
treecbc71a927e36761d82923b729d906482a02c0d80 /configure.ac
parent440f2f9bdcc95c6ccb4074c0ecfeef10aa598350 (diff)
downloadcifs-utils-8ddbdf13169ac38ef7fe552de5abc683e6d63c0f.tar.gz
cifs-utils-8ddbdf13169ac38ef7fe552de5abc683e6d63c0f.tar.bz2
cifs-utils-8ddbdf13169ac38ef7fe552de5abc683e6d63c0f.zip
cifs.upcall: use non-legacy krb5.h location
<krb5.h> is deprecated in favor of <krb5/krb5.h>. Also, make autoconf throw a more helpful error message if it's not present. Signed-off-by: Jeff Layton <jlayton@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a34b136..5a859a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,8 +15,9 @@ AC_GNU_SOURCE
# Checks for libraries.
# Checks for header files.
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h mntent.h netdb.h stddef.h stdint.h stdlib.h string.h strings.h sys/mount.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h krb5.h], , [AC_MSG_ERROR([necessary header(s) not found])])
-AC_CHECK_HEADERS([talloc.h], , [AC_MSG_ERROR([necessary header not found, install libtalloc-devel])])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h mntent.h netdb.h stddef.h stdint.h stdlib.h string.h strings.h sys/mount.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h], , [AC_MSG_ERROR([necessary header(s) not found])])
+AC_CHECK_HEADERS([talloc.h], , [AC_MSG_ERROR([talloc.h not found, install libtalloc-devel])])
+AC_CHECK_HEADERS([krb5/krb5.h], , [AC_MSG_ERROR([krb5/krb5.h not found, install krb5-devel])])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL