summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2010-12-28 14:21:34 -0500
committerJeff Layton <jlayton@samba.org>2010-12-28 09:23:56 -0500
commit99dfd04655aab3a8e6ea03184a32e360f23df9ad (patch)
tree4418345185ef1d097f730aa82372ac986d1a75d2 /configure.ac
parent1d8859b4111a363d30bd3256660e77a216e82a83 (diff)
downloadcifs-utils-99dfd04655aab3a8e6ea03184a32e360f23df9ad.tar.gz
cifs-utils-99dfd04655aab3a8e6ea03184a32e360f23df9ad.tar.bz2
cifs-utils-99dfd04655aab3a8e6ea03184a32e360f23df9ad.zip
cifs.upcall: use krb5_auth_con_set_req_cksumtype() and pass a GSSAPI checksum (bug #7890)
Some closed source SMB servers doesn't support all checksum types, so we should try to match windows clients. This is almost the same logic which is used by Samba. Signed-off-by: Stefan Metzmacher <metze@samba.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 093b48d..53b698d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,6 +133,7 @@ fi
# non-critical functions (we have workarounds for these)
if test $enable_cifsupcall != "no"; then
AC_CHECK_FUNCS([krb5_principal_get_realm krb5_free_unparsed_name])
+ AC_CHECK_FUNCS([krb5_auth_con_setaddrs krb5_auth_con_set_req_cksumtype])
fi
LIBS=$cu_saved_libs