summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authoratheik <atteh.mailbox@gmail.com>2022-05-01 00:47:54 +0300
committerPavel Shilovsky <piastryyy@gmail.com>2022-06-13 10:45:18 -0700
commitd9f5447afbbe7d54f1315e6e2a246fc1a1fce311 (patch)
tree9f7c0bbbe045070562dea79e54db46286bf32ca9 /configure.ac
parent5e5aa507f4c4954ed537a7dfc75cf69915727757 (diff)
downloadcifs-utils-d9f5447afbbe7d54f1315e6e2a246fc1a1fce311.tar.gz
cifs-utils-d9f5447afbbe7d54f1315e6e2a246fc1a1fce311.tar.bz2
cifs-utils-d9f5447afbbe7d54f1315e6e2a246fc1a1fce311.zip
cifs-utils: make GSSAPI usage compatible with Heimdal
The gssapi symbols are in gssapi_krb5 and gssapi in MIT and Heimdal Kerberos, respectively. Including gssapi_generic.h is not necessary. Signed-off-by: atheik <atteh.mailbox@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b1aae6..d78b75d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -208,6 +208,12 @@ if test $enable_cifsupcall != "no"; then
[ KRB5_LDADD='-lkrb5' ],
AC_MSG_ERROR([no functioning krb5 library found!]))
AC_SUBST(KRB5_LDADD)
+ save_LIBS=$LIBS
+ AC_SEARCH_LIBS([gss_init_sec_context], [gssapi_krb5 gssapi],
+ [ GSSAPI_LDADD="$ac_cv_search_gss_init_sec_context" ],
+ AC_MSG_ERROR([no functioning gssapi library found!]))
+ LIBS=$save_LIBS
+ AC_SUBST(GSSAPI_LDADD)
fi
# checks for wbclient.h and libwbclient.so library