summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2010-04-01 15:28:57 -0400
committerJeff Layton <jlayton@redhat.com>2010-04-01 15:28:57 -0400
commitda54228cd9e6fe144efcb2d6da87e3cbb5db5b4c (patch)
tree637b63873a366cd5a98977cc4c75e3c05f6238e0 /configure.ac
parent810f7e4e0f2dbcbee0294d9b371071cb08268200 (diff)
downloadcifs-utils-da54228cd9e6fe144efcb2d6da87e3cbb5db5b4c.tar.gz
cifs-utils-da54228cd9e6fe144efcb2d6da87e3cbb5db5b4c.tar.bz2
cifs-utils-da54228cd9e6fe144efcb2d6da87e3cbb5db5b4c.zip
mount.cifs: drop capabilities if libcap is available
Might as well be as safe as possible. Have child drop all capabilities, and have the parent drop all but CAP_SYS_ADMIN (needed for mounting) and CAP_DAC_OVERRIDE (needed in case mtab isn't writable by root). We might even eventually consider being clever and dropping CAP_DAC_OVERRIDE when root has access to the mtab. Signed-off-by: Jeff Layton <jlayton@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f00bea..46a5848 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,7 @@ AC_INIT([cifs-utils], [4.1], [jlayton@samba.org], [cifs-utils], [http://samba.or
AC_CONFIG_SRCDIR([replace.h])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile])
+AC_CONFIG_MACRO_DIR(aclocal)
AM_INIT_AUTOMAKE
@@ -80,4 +81,6 @@ fi
AM_CONDITIONAL(CONFIG_CIFSUPCALL, [test "$enable_cifsupcall" != "no"])
+AC_LIBCAP
+
AC_OUTPUT