summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Layton <jlayton@samba.org>2010-04-05 11:23:32 -0400
committerJeff Layton <jlayton@samba.org>2010-04-05 11:23:32 -0400
commitda77c1b3ae934e29025d05b50eebecdbf569bfa4 (patch)
treec36894d2d7f7100bb5fb5704a6c1c6b296528084 /configure.ac
parent4b52d2fdea00107f3c23388891467bbb7f2711eb (diff)
downloadcifs-utils-da77c1b3ae934e29025d05b50eebecdbf569bfa4.tar.gz
cifs-utils-da77c1b3ae934e29025d05b50eebecdbf569bfa4.tar.bz2
cifs-utils-da77c1b3ae934e29025d05b50eebecdbf569bfa4.zip
mount.cifs: properly prune the capabilities bounding set
...libcap-ng does this in a much easier fashion. If that's not available, then we have to do it manually. Signed-off-by: Jeff Layton <jlayton@samba.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 857b0d8..d734d62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,9 @@ AC_FUNC_STRNLEN
# check for required functions
AC_CHECK_FUNCS([alarm atexit endpwent getmntent getpass gettimeofday inet_ntop memset realpath setenv strchr strdup strerror strncasecmp strndup strpbrk strrchr strstr strtol strtoul uname], , [AC_MSG_ERROR([necessary functions(s) not found])])
+# check for prctl
+AC_CHECK_FUNCS([prctl])
+
# ugly, but I'm not sure how to check for functions in a library that's not in $LIBS
cu_saved_libs=$LIBS
LIBS="$LIBS $KRB5_LDADD"