summaryrefslogtreecommitdiff
path: root/contrib/request-key.d/Makefile.am
diff options
context:
space:
mode:
authorJeff Layton <jlayton@samba.org>2011-12-10 06:49:33 -0500
committerJeff Layton <jlayton@samba.org>2011-12-10 06:49:33 -0500
commit2a9738cefaf8a9496ff0683e18357b3548da0b28 (patch)
tree8df55b6787099bb63177e1149334d320c0201d97 /contrib/request-key.d/Makefile.am
parentc3fff275e873fd9b9639124e993dd4ad737614db (diff)
downloadcifs-utils-2a9738cefaf8a9496ff0683e18357b3548da0b28.tar.gz
cifs-utils-2a9738cefaf8a9496ff0683e18357b3548da0b28.tar.bz2
cifs-utils-2a9738cefaf8a9496ff0683e18357b3548da0b28.zip
contrib: add a set of sample /etc/request-key.d files
Add a contrib directory, a set of sample /etc/request-key.d files and a README that explains what they're for. This version sets the path to the upcall programs based on the configure options. Signed-off-by: Jeff Layton <jlayton@samba.org>
Diffstat (limited to 'contrib/request-key.d/Makefile.am')
-rw-r--r--contrib/request-key.d/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/contrib/request-key.d/Makefile.am b/contrib/request-key.d/Makefile.am
new file mode 100644
index 0000000..5bda10d
--- /dev/null
+++ b/contrib/request-key.d/Makefile.am
@@ -0,0 +1,9 @@
+noinst_DATA = cifs.idmap.conf cifs.spnego.conf
+cifs.idmap.conf: cifs.idmap.conf.in
+ $(SED) 's,[@]sbindir@,$(sbindir),' $(srcdir)/$@.in > $@-t && mv $@-t $@
+
+cifs.spnego.conf: cifs.spnego.conf.in
+ $(SED) 's,[@]sbindir@,$(sbindir),' $(srcdir)/$@.in > $@-t && mv $@-t $@
+
+clean-local:
+ rm -f cifs.idmap.conf cifs.spnego.conf